[Spce-user] DB table ngcp.db_schema contains wrong value

Max Power mpower at entelit.ca
Sun Jan 11 14:26:31 EST 2015

Thanks Alex and Marc for your assistance!

We tried to run the upgrade again this weekend but ended up at the same

This time when running the upgrade we got the error:

Error: DB table ngcp.db_schema contains duplicated revisions: 5471
Please execute: mysql -uroot ngcp -e "delete n2 FROM db_schema n1, db_schema
n2 WHERE n1.revision = n2.revision AND n1.node IN ('spce','') AND n2.node
NOT IN ('spce','');"

After running the command successfully we tried to update again. We were
presented with the same message as before:
Error: DB table ngcp.cfg_schema contains wrong value.
Please execute: mysql -uroot -e "update ngcp.cfg_schema set node='spce'"

Tried executing that command and although there were no errors the upgrade
script still won't run.

Is there anything else it might be? Before rolling back the changes we tried
clearing the data from that table. The update ran but because that table was
empty it wanted to reinitialize the database. Agreeing to that, it still
presented errors. We then tried just updating the packages and such with an
"apt-get update && apt-get upgrade && ngcp-update-db-schema &&
ngcp-update-cfg-schema && ngcpcfg apply". That seemed to work just fine. The
upgrade script still fails with the same error. 

We ended up just rolling back to the working snapshot. Attached is the
db_schema table after deleting the duplicates with the first command.

Maxwell Power

-----Original Message-----
From: Spce-user [mailto:spce-user-bounces at lists.sipwise.com] On Behalf Of
Alex Lutay
Sent: Wednesday, 07 January 2015 6:52 AM
To: spce-user at lists.sipwise.com
Subject: Re: [Spce-user] DB table ngcp.db_schema contains wrong value

Hi all!

Max, thank you for pointing the problem and thank you to Marc for
clarification. I have pushed the additional in schema tables.
So, for now users will see:
> Error: DB table ngcp.db_schema contains duplicated revisions: 12345 
> Please execute: mysql -uroot ngcp -e "delete n2 FROM $TABLE n1, $TABLE n2
WHERE n1.revision = n2.revision AND n1.node IN ('spce','') AND n2.node NOT
IN ('spce','');"
The fixes are in trunk and mr3.6 and will be hotfixed to mr3.6.1/mr3.6.2 as
soon as pass all the auto-upgrade tests.

Thank you!

On 05/01/15 18:11, Marc Storck wrote:
> I had them same issue, it turned out that my db_schema table had 
> duplicate entries for certain revisions (1 line with node=$hostname 
> and
> 1 line with node=spce).
> I had to manually remove the duplicated where node=$hostname.
> Please replace $hostname with the value that shows up in your table.
> Regards,
> Marc
>> On 05 Jan 2015, at 17:59, Max Power <mpower at entelit.ca 
>> <mailto:mpower at entelit.ca>> wrote:
>> Hi All,
>> When trying to update from 3.6.1 to 3.6.2 we are getting an error we 
>> have been unable to move past. The system is otherwise up to date. We 
>> have tried running the command it suggested and poked through the 
>> database. We haven't been able to resolve. Any advice?
>> *Error: DB table ngcp.db_schema contains wrong value.* *Please 
>> execute 'mysql -uroot "update ngcp.db_schema set node='spce'"'*

Alexander Lutay
Head of Quality Assurance
Sipwise GmbH, Campus 21/Europaring F15
AT-2345 Brunn am Gebirge

Office: +43(0)13012036
Email: alutay at sipwise.com
Website: http://www.sipwise.com

Meet us @ AFRICACOM : Booth A17/A18
11-13 November 2014 : CTICC Cape Town, South Africa
Spce-user mailing list
Spce-user at lists.sipwise.com
-------------- next part --------------
A non-text attachment was scrubbed...
Name: db_schema.csv
Type: application/vnd.ms-excel
Size: 10143 bytes
Desc: not available
URL: <http://lists.sipwise.com/pipermail/spce-user_lists.sipwise.com/attachments/20150111/99cfa66c/attachment-0001.csv>

More information about the Spce-user mailing list