[Spce-user] Has anyone managed to get HOMER to work?

Matthias Hohl matthias.hohl at telematica.at
Fri Mar 10 03:09:31 EST 2017



yes Homer is supported and i also run Homer Capture Clients on SPCE and send
it to my Homer Server.


I use 

·         rtpengine for RTCP Stats (

·         captagent for SIP packages (

·         hepipe for Log (


you can also use captagent for RTCP stats also
 this is default if you
install captagent, so you must deactivate RTCP stats in captagent config
files to use just the rtpengine (it is more performance)


to check if packages get sent to your homer server you can check this:




all Traffic:

ngrep -W byline port 9060 and host YOUR-HOMER-IP


Nur Log Traffic (Hepipe)

ngrep -W byline port 9060 | grep proxy


Nur RTCP Stats (rtpengine)

ngrep -W byline port 9060 | grep sender


Nur SIP traffic (Captagent)

ngrep -W byline port 9060 | grep sip




AT Homer Server you can do this for checking if something is coming:

ngrep -W byline port 9060 and host YOUR-SPCE-SERVER-IP


Von: Spce-user [mailto:spce-user-bounces at lists.sipwise.com] Im Auftrag von
William Fulton
Gesendet: Freitag, 10. März 2017 03:11
An: William Hilsum <William at ezpcltd.com>; spce-user at lists.sipwise.com
Betreff: Re: [Spce-user] Has anyone managed to get HOMER to work?




Are you using a network tap in your hardware configuration?  I haven’t used
homer yet, but I know for doing these kinds of captures it is often
required.  Some Cisco switches have a tap port built in, if you don’t have
this type of hardware try doing a search for Network Tap.  Here are some
that I have used with good results:

 <https://www.amazon.com/dp/B002BSF112> https://www.amazon.com/dp/B002BSF112


 <https://www.amazon.com/dp/B0175EODCE> https://www.amazon.com/dp/B0175EODCE


Good luck!

Bill in Seattle


From: Spce-user [ <mailto:spce-user-bounces at lists.sipwise.com>
mailto:spce-user-bounces at lists.sipwise.com] On Behalf Of William Hilsum
Sent: Thursday, March 9, 2017 5:16 PM
To:  <mailto:spce-user at lists.sipwise.com> spce-user at lists.sipwise.com
Subject: [Spce-user] Has anyone managed to get HOMER to work?




I am trying to diagnose an issue for a client and am getting a bit fed up of
tracing through Wireshark.


I have seen Homer for some time and had a few hours spare, so, I thought I
would set it up


I edited my config.yml homer section to:



  capture_id: 'homer01'

  capture_pass: 123

  enabled: yes

  host: --homer-ip-address

  port: '9060'


“Ngcpcfg build” followed by “ngcp apply homer”


I setup a new box, installed Debian and ran the install script as per the
instructions on github. There were a few errors relating to region settings
– but, it looks like everything installed fine (Mysql, Apache etc.).


I can see the web interface fine, but, it just doesn’t get populated with


I ran “tcpdump host –homer-ip-address” and couldn’t see anything. I then ran
“sngrep -H udp:--homer-ip-address:9060” along with “ngrep -W byline port
9060” on the Homer server, and, I could see the HEP packets coming through.


So, I was wondering:

Is Homer supported on community edition/did I do something wrong? (I wasn’t
sure what capture_pass is / I tried various default passwords)

Has anyone managed to get it work?

Can anyone give me some hints? I can’t see any community/IRC etc.






-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sipwise.com/pipermail/spce-user_lists.sipwise.com/attachments/20170310/472efbf4/attachment-0001.html>

More information about the Spce-user mailing list