[Spce-user] Sipwise CE 6.5,3 installation issues

Manuel Montecelo mmontecelo at sipwise.com
Fri Jan 25 05:54:40 EST 2019


2019-01-24 19:11 rleone.soluzioni at libero.it:
>after installed new sipwise (versions ex. 6.5.1->6.5.3) and rebooted software not working. I noticed that in /etc/ngcp-config are missing many files.

I performed upgrades both in our automated test infra and a VM installing and
upgrading manually, following instructions in [1], and I didn't detect any
problem.  Automated tests were run, including checks about mysql and other
config, and no problem was detected.

  [1] https://docs.mgm.sipwise.com/public/mr6.5.3/spce/?_href=ar01s14.html

But these are pristine systems, the config if the system is different in your
case, and the network too.  Do you still have the log of this upgrade?  It
should be in /var/log/, with a name similar to:


>The installation is incomplete. The command ngcp-status :
># ngcp-status
>Debian 9,7 stretch + Sipwise C5 installer package
>+-------------------------------------+---------------------------------------------- 2019-01-24 17:51:51 --------------------------------+
>|          	| NGCP: CE mr6.5.3                                                   					|
>|                           		|  WAN: failed to ping 'debian.sipwise.com'                          				|
>|                           		| NGCP: No line with GRUB_CMDLINE_LINUX_DEFAULT containing net.ifnames=0 |
>|                           		| 	    in  /etc/default/grub 									|

Does the network work at all in that system?  Can you ping to outside servers?

>After installation with CD (sip_provider_mr6.5.3.iso)
>Warning: cannot read /etc/mysql/sipwise.cnf, continue anyway
>Warning: cannot read /etc/ngcp-status/ngcp-status.conf, using default values
>du: cannot access '/ngcp-data/mysql/': No such file or directory
>2019-01-24 18:57:14 : Error: Configuration file /etc/ngcp-config/config.yml does not exist (unconfigured?) - exiting.
>2019-01-24 18:57:20 : Error: Configuration file /etc/ngcp-config/config.yml does not exist (unconfigured?) - exiting.
># ngcp-status
>|                           		|  WAN: failed to ping 'debian.sipwise.com'                                              |

Same problem about connectivity detected.

>I tried to install sipwise CE on Virtual Box with same results. Tried on OVH's dedicated server too but installation failed

I can install sucessfully with the instructions in:


Also with the .iso and installing in virtualbox, as per:


It looks like the images themselves work fine, but they fail to configure the
system properly to be able to use the network in your case, or there's an
unrelated config in your network that it's preventing the system from working

If you can share the logs of the installations/upgrades, in /var/log/ngcp-*, we
can look into it in more detail.

Manuel Montecelo <mmontecelo at sipwise.com>
Release Engineer

Sipwise GmbH, Campus 21/Europaring F15
AT-2345 Brunn am Gebirge

Office: +43(0)13012029 | Website: https://www.sipwise.com

More information about the Spce-user mailing list