[Spce-user] kamailio-lb won't start with TLS enabled

Jon Bonilla (Manwe) jbonilla at sipwise.com
Mon May 14 16:26:50 EDT 2012

El Thu, 19 Apr 2012 02:01:06 -0700
Skyler <skchopperguy at gmail.com> escribió:

> Hi,
>  I've just started testing with TLS on SPCE 2.4 and when tls is enabled in
> config.yml then kamailio-lb will not start. The below warnings are
> in kamailio-lb.log
> WARNING: <core> [cfg.y:3396]: warning in config file
> /etc/kamailio/lb/kamailio.cfg, line 34, column 13: sctp support not
> compiled in
> WARNING: tls [tls_init.c:587]: tls: openssl bug #1491 (crash/mem leaks on
> low memory) workaround enabled (on low memory tls operations will fail
> preemptively) with free memory thresholds 6291456 and 3145728 bytes
>  I looked up enable_sctp=0 in kamailio docs and that shows 'disabled', also
> I tried 'disable_sctp = yes' instead as indicated for 3.2 but neither make
> any difference. The warning about memory thresholds has me thinking maybe
> kamailio requires certain minimum of memory at runtime, how can I increase
> the memory used by kamailio-lb at runtime?
> Thanks,
> Skyler

Sorry, I don't see follow ups to this thread. Was this solved somehow?

More information about the Spce-user mailing list