[Spce-user] Help with upgrade...

Derrick Bradbury derrickb at halex.com
Thu Jan 22 11:37:41 EST 2015

Thanks for the help, but I finally figured it out....

The issue was I had a virtual interface defined for a failover, and in the network.yml file I had both the primary and virtual interface defined (without the "#" initially):

#    eth0:
#      ip: AAA.XXX.XXX.28
#      netmask:
#      type:
#        - web_ext
#        - sip_ext
#        - rtp_ext
#        - ssh_ext
#        - web_int
      ip: AAA.XXX.XXX.30
        - web_int
        - web_ext
        - sip_ext
        - rtp_ext
        - ssh_ext
The requests were coming in on .30 and the responses were going OUT on .28, so end clients weren't getting the proper responses. 

Commented out ETH0, and re-applied, and everything worked fine.

It worked from 3.2.1 but not 3.7.1... and it wasn't until I told my firewall sniffer to watch the entire subnet did I notice that!

From: Andrew Pogrebennyk [apogrebennyk at sipwise.com]
Sent: Thursday, January 22, 2015 10:49 AM
To: Derrick Bradbury; "spce-user ‎[spce-user at lists.sipwise.com]‎"
Subject: Re: [Spce-user] Help with upgrade...

this looks like the response is simply not coming, but I'm not sure
because the log you provided contains only BYE message. Check the
'ngrep-sip b' and kamailio-lb.log, if unsure how to interpret this then
please share somehow with me or the list. Also please disable the proxy
debug mode in config.yml if you will be providing the kamailioproxy.log
too, as this is huge and difficult to read (log level 1 or 2 is usually
enough unless we request the debug explicitly).

Hope this helps,

On 01/21/2015 09:02 PM, Derrick Bradbury wrote:
> Something else to add.. on the inbound call. I don't get an "answer" in
> the RTP log:
> (outbound call)
> Jan 21 14:53:31 sipce01 rtpengine[4391]: Got valid command from
> answer - { "sdp":  .....
> On the inbound call, that doesn't show up.. I get:
> Jan 21 14:54:37 sipce01 rtpengine[4391]: [edd375f522f07c59] Call branch
> '533EF9AE-54C003B4000BA0EF-971C8700' deleted, no more branches remaining

More information about the Spce-user mailing list