[Spce-user] NGCP HTTP API with client-certificate gives "400 Bad Request The SSL certificate error"

Christian Benke benkokakao at gmail.com
Wed Mar 4 05:12:29 EST 2015


A few days ago I was using the http api with curl and/or
python-requests to provision a range of alias-numbers. That was
working fine then with client-certificate-authentication. Today I
wanted to repeat this trick, but out of the blue the api/nginx
responds to all SSL-certified requests with "400 Bad Request The SSL
certificate error".
I didn't update the server recently nor where there any changes to the
flatfile-configuration, only additions through the webinterface (I
also added an administrator, which might be the closest relation to
the issue).

I tried it with keys from a different administrator and I tried it
with freshly generated certs to no avail. Unfortunately there is no
information of my failed tries in any of the logs (Including api.log,
panel-debug.log and panel.log) so it's a bit hard to debug.
Using user/password-login instead of client-cert works fine.

Any ideas what the issue could be and how I can find the cause with
starting to disassemble the components?


More information about the Spce-user mailing list