[Spce-user] error 477

rob.van.den.bulk at gmail.com rob.van.den.bulk at gmail.com
Wed May 5 15:24:55 EDT 2021

Hallo Alex,


I use a sipewise 8.5.4 (install 8.5.3 and update it to 8.5.4)

On this server works the registration of the PEER

I made a second one (as a backup) 8.5.4

On this server become I the error when I try to call via the peer (calls on the domain are okay)

Also the peer registration and calls to a peer don’t work on this version.

SIP/2.0 477 Unfortunately error on sending to next hop occurred (477/TM)


This info is clear to me, I read the complete manual! ( I even printed it and made screen prints)



So i try the "new" version of the manual, a little different from the pdf 8.5.4


Registering at a Peering Server

Unfortunately, the credentials configured above are not yet automatically used to register Sipwise C5 at your peer hosts. There is however a manual way to do so, until this is addressed.


Create a new file /etc/ngcp-config/templates/etc/ngcp-sems/etc/reg_agent.conf.customtt.tt2 as a copy of /etc/ngcp-config/templates/etc/ngcp-sems/etc/reg_agent.conf.tt2. Configure your peering servers with the corresponding credentials in the new created file /etc/ngcp-config/templates/etc/ngcp-sems/etc/reg_agent.conf.customtt.tt2, then execute ngcpcfg apply "added upstream credentials". IMPORTANT: Be aware that this will force SEMS to restart, which will drop all calls.


Still no outgoing calls to the peer and no registration of the peer.

Also with no reg of the peer the call won't go, and the same error 477

systemctl status sems (sems is running)

ngcp-status  and ngcpcfg status --local-only (everything okay)


Greetings Rob


PS, I look ad https://www.sipwise.com/products/sipwise-ctp-certified-training-package/  😊


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sipwise.com/pipermail/spce-user_lists.sipwise.com/attachments/20210505/cbb945b2/attachment.html>

More information about the Spce-user mailing list