[Spce-user] Has anyone managed to get HOMER to work?

William Hilsum William at ezpcltd.com
Sat Mar 11 21:08:32 EST 2017

No network tap used here - all virtual machines of same degree, so, would be a PITA to setup (but can just use Hyper V/Vmware port mirroring).

Anyway, hopefully it will be working soon...


From: William Fulton [mailto:wfulton at thirdhatch.com]
Sent: 10 March 2017 02:11
To: William Hilsum <William at ezpcltd.com>; spce-user at lists.sipwise.com
Subject: RE: Has anyone managed to get HOMER to work?


Are you using a network tap in your hardware configuration?  I haven't used homer yet, but I know for doing these kinds of captures it is often required.  Some Cisco switches have a tap port built in, if you don't have this type of hardware try doing a search for Network Tap.  Here are some that I have used with good results:

Good luck!
Bill in Seattle

From: Spce-user [mailto:spce-user-bounces at lists.sipwise.com] On Behalf Of William Hilsum
Sent: Thursday, March 9, 2017 5:16 PM
To: spce-user at lists.sipwise.com<mailto:spce-user at lists.sipwise.com>
Subject: [Spce-user] Has anyone managed to get HOMER to work?


I am trying to diagnose an issue for a client and am getting a bit fed up of tracing through Wireshark.

I have seen Homer for some time and had a few hours spare, so, I thought I would set it up...

I edited my config.yml homer section to:

  capture_id: 'homer01'
  capture_pass: 123
  enabled: yes
  host: --homer-ip-address
  port: '9060'

"Ngcpcfg build" followed by "ngcp apply homer"

I setup a new box, installed Debian and ran the install script as per the instructions on github. There were a few errors relating to region settings - but, it looks like everything installed fine (Mysql, Apache etc.).

I can see the web interface fine, but, it just doesn't get populated with anything.

I ran "tcpdump host -homer-ip-address" and couldn't see anything. I then ran "sngrep -H udp:--homer-ip-address:9060" along with "ngrep -W byline port 9060" on the Homer server, and, I could see the HEP packets coming through.

So, I was wondering:
Is Homer supported on community edition/did I do something wrong? (I wasn't sure what capture_pass is / I tried various default passwords)
Has anyone managed to get it work?
Can anyone give me some hints? I can't see any community/IRC etc.



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.sipwise.com/pipermail/spce-user_lists.sipwise.com/attachments/20170312/5ae48538/attachment-0001.html>

More information about the Spce-user mailing list